Note: The other languages of the website are Google-translated. Back to English

Jak počítat počet buněk s nenulovými hodnotami v aplikaci Excel?

Pro počítání celkového počtu buněk s nenulovými hodnotami v aplikaci Excel vám ukážeme dvě metody. Prohlédněte si další podrobnosti.

Počítat počet buněk s nenulovými hodnotami pomocí vzorce
Spočítat počet buněk s nenulovými hodnotami pomocí programu Kutools pro Excel


Počítat počet buněk s nenulovými hodnotami pomocí vzorce

Předpokládejme, že máte řadu dat, jak je uvedeno níže. Chcete-li počítat počty buněk s nenulovými hodnotami, postupujte takto.

1. Vyberte prázdnou buňku pro vyhledání výsledku počítání (zde vyberu buňku H1). Zkopírujte a vložte vzorec = COUNTIF (A1: E8, "<> 0") do Formula Bar, a poté stiskněte tlačítko vstoupit klíč. Viz snímek obrazovky:

2. Poté se spočítá celkový počet nenulových hodnot vybraného rozsahu a zobrazí se v buňce H1.

Poznámky:

1. S výše uvedeným vzorcem můžete počítat nenulové buňky, včetně prázdných buněk. Pokud chcete ignorovat nulové i prázdné buňky, použijte tento vzorec: =COUNTA(A1:D10)-COUNTIF(A1:D10,"=0"), Poté stiskněte tlačítko vstoupit klíč k získání výsledku, viz screenshot:

2. U výše uvedených vzorců můžete počítat celkový počet buněk s nenulovými hodnotami v řádku, sloupci nebo rozsahu v aplikaci Excel se změnou odkazů na buňky ve vzorci.


Spočítat počet buněk s nenulovými hodnotami pomocí programu Kutools pro Excel

Kromě vzorců, Vyberte konkrétní buňky užitečnost Kutools pro Excel vám pomůže rychle spočítat počet buněk s nenulovými hodnotami v aplikaci Excel.

Před aplikací Kutools pro Excel, Prosím nejprve si jej stáhněte a nainstalujte.

1. Vyberte rozsah, ve kterém chcete spočítat počet nenulových buněk. Poté klikněte Kutools > vybrat > Vyberte konkrétní buňky. Viz snímek obrazovky:

2. Ve vyskakovacím okně Vyberte konkrétní buňky dialogové okno vyberte Buňka v Typ výběru sekce, upřesněte Nerovná se v Specifický typ rozevírací seznam a zadejte číslo 0 do prázdného pole. Nakonec klikněte na OK knoflík. Viz screenshot:

3. Poté se zobrazí dialogové okno, které vám řekne, kolik nenulových buněk existuje ve vybraném rozsahu. A prázdné buňky již přímo vyloučil. Klikněte na ikonu OK tlačítko, jsou tyto buňky vybrány okamžitě.

  Pokud chcete mít bezplatnou zkušební verzi (

30
-den) této utility, kliknutím jej stáhněte, a poté přejděte k použití operace podle výše uvedených kroků.

Nejlepší kancelářské nástroje produktivity

Kutools pro Excel vyřeší většinu vašich problémů a zvýší vaši produktivitu
80%

  • Opakované použití: Rychle vložte složité vzorce, grafy a cokoli, co jste dříve používali; Šifrovat buňky s heslem; Vytvořte seznam adresátů a posílat e-maily ...
  • Super Formula Bar (snadno upravit více řádků textu a vzorce); Rozložení pro čtení (snadno číst a upravovat velké množství buněk); Vložit do filtrovaného rozsahu...
  • Sloučit buňky / řádky / sloupce bez ztráty dat; Rozdělit obsah buněk; Zkombinujte duplicitní řádky / sloupce... Zabraňte duplicitním buňkám; Porovnat rozsahy...
  • Vyberte možnost Duplikovat nebo Jedinečný Řádky; Vyberte prázdné řádky (všechny buňky jsou prázdné); Super hledání a fuzzy hledání v mnoha sešitech; Náhodný výběr ...
  • Přesná kopie Více buněk beze změny odkazu na vzorec; Automaticky vytvářet reference do více listů; Vložte odrážky, Zaškrtávací políčka a další ...
  • Extrahujte text, Přidat text, Odebrat podle pozice, Odebrat mezeru; Vytváření a tisk mezisoučtů stránkování; Převod mezi obsahem buněk a komentáři...
  • Super filtr (uložit a použít schémata filtrů na jiné listy); Rozšířené řazení podle měsíce / týdne / dne, frekvence a dalších; Speciální filtr tučnou kurzívou ...
  • Kombinujte sešity a pracovní listy; Sloučit tabulky na základě klíčových sloupců; Rozdělte data do více listů; Dávkový převod xls, xlsx a PDF...
  • Více než
    300
    výkonné funkce
    . Podporuje Office/Excel
    2007-2019 a 365
    . Podporuje všechny jazyky. Snadné nasazení ve vašem podniku nebo organizaci. Plné funkce
    30
    -denní zkušební verze zdarma. 60denní záruka vrácení peněz.
karta kte 201905

Office Tab přináší do Office rozhraní s kartami a usnadňuje vám práci

  • Povolte úpravy a čtení na kartách ve Wordu, Excelu, PowerPointu, Publisher, Access, Visio a Project.
  • Otevřete a vytvořte více dokumentů na nových kartách ve stejném okně, nikoli v nových oknech.
  • Zvyšuje vaši produktivitu tím
    50%
    a každý den vám sníží stovky kliknutí myší!
officetab dno
Komentáře (5)
Zatím žádné hodnocení. Buďte první, kdo ohodnotí!
Tento komentář byl moderátorem webu minimalizován
Otázka: Jak počítat nenulovou buňku.
Ans. =COUNTIF(F26:Q26;">0")
Tento komentář byl moderátorem webu minimalizován
Děkuji za tvoji snahu
Tento komentář byl moderátorem webu minimalizován
=CONT.SE(AL27:AL31;">0")
Tento komentář byl moderátorem webu minimalizován
DĚKUJI ZA VAŠE INFORMACE
Tento komentář byl moderátorem webu minimalizován
BRILLIANT ..toto jsem hledal 4 hodiny a každý další odborník mi dal ty nejsložitější vzorce, které nikdy nefungovaly. vzorec: =POČET(A1:D10)-POČET(A1:D10,"=0"),

thx vás
Zatím zde nejsou žádné komentáře
Zanechat své připomínky
Odesílání jako host
×
Ohodnoťte tento příspěvek:
0   Postavy
Doporučená umístění

Sociální sítě

Copyright © 2009 - www.extendoffice.com. | Všechna práva vyhrazena. Poháněno ExtendOffice. | |. | Sitemap
Microsoft a logo Office jsou ochranné známky nebo registrované ochranné známky společnosti Microsoft Corporation ve Spojených státech a / nebo jiných zemích.
Chráněno Sectigo SSL